Directories
¶
| Path | Synopsis |
|---|---|
|
Package acceptquery advertises and enforces HTTP QUERY request formats as defined by RFC 10008.
|
Package acceptquery advertises and enforces HTTP QUERY request formats as defined by RFC 10008. |
|
Package cache provides bounded in-memory HTTP response caching.
|
Package cache provides bounded in-memory HTTP response caching. |
|
Package coalesce provides request coalescing middleware.
|
Package coalesce provides request coalescing middleware. |
|
Package contentdigest implements RFC 9530 Content-Digest verification and response generation.
|
Package contentdigest implements RFC 9530 Content-Digest verification and response generation. |
|
Package csrf implements a signed, browser-session-bound, origin-aware double-submit CSRF defense for fh.
|
Package csrf implements a signed, browser-session-bound, origin-aware double-submit CSRF defense for fh. |
|
Package decompress provides bounded request decompression.
|
Package decompress provides bounded request decompression. |
|
Package earlydata protects non-idempotent requests replayed as TLS early data.
|
Package earlydata protects non-idempotent requests replayed as TLS early data. |
|
Package fetchmetadata implements W3C Fetch Metadata Request Headers security policies.
|
Package fetchmetadata implements W3C Fetch Metadata Request Headers security policies. |
|
Package httpsignature signs FH responses using the Ed25519 response profile implemented by pkg/httpsignature and the wire format defined by RFC 9421.
|
Package httpsignature signs FH responses using the Ed25519 response profile implemented by pkg/httpsignature and the wire format defined by RFC 9421. |
|
Package policy groups cross-cutting route metadata with middleware policies.
|
Package policy groups cross-cutting route metadata with middleware policies. |
|
Package rewrite performs bounded internal request rewrites.
|
Package rewrite performs bounded internal request rewrites. |
|
Package securetransport provides application-layer encrypted, device-bound, replay-resistant request/response transport for fh applications.
|
Package securetransport provides application-layer encrypted, device-bound, replay-resistant request/response transport for fh applications. |
|
Package servertiming provides Server-Timing header support per RFC 8638.
|
Package servertiming provides Server-Timing header support per RFC 8638. |
|
Package skip conditionally bypasses middleware.
|
Package skip conditionally bypasses middleware. |
|
Package slidingwindow provides a sliding window rate limiter middleware.
|
Package slidingwindow provides a sliding window rate limiter middleware. |
|
Package smartcache provides RFC 7234 compliant HTTP caching middleware.
|
Package smartcache provides RFC 7234 compliant HTTP caching middleware. |
|
Package static serves files as route handlers with cache and download controls.
|
Package static serves files as route handlers with cache and download controls. |
|
Package validate provides request validation middleware for fh.
|
Package validate provides request validation middleware for fh. |
Click to show internal directories.
Click to hide internal directories.