Directories
¶
| Path | Synopsis |
|---|---|
|
Package duration copied as it is from github.com/senseyeio/duration
|
Package duration copied as it is from github.com/senseyeio/duration |
|
Package gitutil provides utilities for working with git repositories.
|
Package gitutil provides utilities for working with git repositories. |
|
Package oauthclient implements the client side of OAuth 2.1 authorization code flows against protected resources: discovery of the resource's authorization server (RFC 9728 and RFC 8414), dynamic client registration (RFC 7591) with a pre-registered fallback, PKCE, resource indicators (RFC 8707), issuer validation (RFC 9207), token refresh with rotation, and revocation (RFC 7009).
|
Package oauthclient implements the client side of OAuth 2.1 authorization code flows against protected resources: discovery of the resource's authorization server (RFC 9728 and RFC 8414), dynamic client registration (RFC 7591) with a pre-registered fallback, PKCE, resource indicators (RFC 8707), issuer validation (RFC 9207), token refresh with rotation, and revocation (RFC 7009). |
|
Package safehttp provides HTTP clients for requests to URLs taken from project files.
|
Package safehttp provides HTTP clients for requests to URLs taken from project files. |
|
Package singleflight provides a duplicate function call suppression mechanism.
|
Package singleflight provides a duplicate function call suppression mechanism. |
|
Package urlutils provides helpers for producing URL-safe strings.
|
Package urlutils provides helpers for producing URL-safe strings. |
Click to show internal directories.
Click to hide internal directories.